Misfire | 1999 GMC Safari Van | 4.3

Defective New Crank Sensor Produces Tiny Signal Glitch and Causes Misfires

My first case study is on a 1999 GMC Safari van with a 4.3 liter. This was the first job Dewitz Diagnostic Solutions did for this new business account. The complaint was a bad misfire on cylinder #2 with some other random misses on the other cylinders. This vehicle had a poor maintenance record so the shop did a basic tune-up to get the ball rolling.

The van still had the miss when hot and was also setting a P01345 cam crank correlation error code along with the basic P0300 and P0302. After they tried a used distributor (cam sensor) with no change and ran out of ideas they gave me a call. I came to there shop (one of the cleanest in town) and took a look at the GMC. I also pulled the same codes they had and he also showed me that when it starts to misfire, you can hear the spark snapping inside the distributor cap. While watching the cam retard on my Tech II, I saw it jumping all over the place from -8 degrees to -21 degrees. What could cause this? The cam retard should be holding steady at around -10 degrees at 1000 rpm. Well a bad cam sensor, timing chain, distributor gear, crank sensor, excess crankshaft end play could all cause this. GM’s trouble tree for code P01345 pretty much states that at 1000 rpm you should have between -5 degrees and -15 degrees and if you rev the engine to 2000 rpm there should be no more than a 2 degree change. If there is more than a 2 deg. change, replace the distributor (cam sensor). So I scoped the cam and crank signals together to see if they stayed in sync or not. No matter what I did with the engine rpm’s the cam and crank signals did not move more than a degree from each other if that. After some final checks I didn’t really have a conclusive answer except that the VCM could be faulty causing the cam retard to jump all over even though it wasn’t.

Back at his shop and with a new approach I scoped the crank signal at the sensor and at the VCM to make sure we had no voltage drops in our signal wire to the VCM. We didn’t but the problem became very clear to me now. When it would start missing the top of the crank signal would start dropping out a little especially in one spot causing the #2 cyl. misfire. A bad tooth on the crank could cause one spot to keep dropping out but I could see that it was dropping out in other spots also, just not as consistently. It was a new crank sensor that was faulty. Both images with the cam and crank sensors where captured that the first night and you can clearly see the problem. Well, I was more interested to see if they were staying in sync with each other than anything else and with all the noise on the cam sensor (upside down primary coil amperage and secondary spark kv) I just figured the same was on the crank signal. Also after using a scope day to day you learn not to over analyze all of your scope patterns because you do get different types of interference that you have to learn to ignore so you don’t replace good parts. What I learned this night was that there is a fine line between over analyzing and under analyzing and sometimes when your stuck on an idea to let it go and try to see it from another perspective.

Leave any questions or comments below. Thank you.


Automotive Diagnostic Scope Training ManualThe Automotive Scan Tool, Scope, and Waveform Training Manual is just over 40 COLOR pages long and is full of images, tests, information, tables, conversions, and common problems. This manual is focused on advanced beginners and intermediate users. Advanced users would also find this manual very handy. The main focus of the manual is on scope usage, interpreting waveforms, and utilizing your graphing scan tool(s).

Great guide for Snap-On Modis, Versus, and Vantage Pro users but the manual is designed for all automotive scopes in mind. This great resource includes useful charts and tables, scope waveforms, graphing scan tool testing tips and tricks, along with scope test lead and low amp probe test hook up location diagrams. Sensor tests include O2, TPS, VSS, MAF, CKP, CMP and MAP. Other component testing includes fuel pumps, coils, starters, blower motors, and fuel injectors. Ford Mode 6 misfire diagnostics and Ford coil on plug (COP) testing tricks included. Tricks include two test lead hook-ups to diagnose how many coils and which cylinder coils are bad, even before the customer knows! Download Now – $15

Comments (25)

  1. Alan Stevens

    I have the same gmc safari 1999 and I am getting the same error the misfire on cylinder 3 I read your above post and was wondering if this is the likely answer

  2. Travis Dewitz

    It is possible but the problem above is not very common. I would start with the basics first especially checking the injector poppets.

  3. Eric Sandquist

    We are having a similar issue. 1998, misfire, codes say random misfire, but based on pulling plugs off the distributor it is Cyl 1. Just don’t know why – sensors? Injector?… I can do the parts swap, but need to isolate the cause, can’t afford to just throw parts at it and really don’t want to take the intake apart unless I know it is the injector array.

    • Travis Dewitz

      Your next step would to do a injector pressure drop test. That will isolate the problem to the injectors and which one.

  4. Have a 1999 Olds Bravada. it has a #1 and 3 misfire. There are occasional misfire on #2 and 4. there is no problems on #5 and 6. Did the pressure bleed down and found a problem on the spray pattern on #1 and 3. Replaced the spider and the same problem. The fuel pressure is 55 and the filter is good. Compression is steady across the board. I have some good training thru the military. this has me confused. thanks for some help

    • Travis Dewitz

      Random misfires can be hard to track down. Defective distributor caps are common to cause random misfires. When does it misfire? Idle, under load? Valve springs, egr, vacuum leaks, plugs, fuel quality are just a few ideas. Would really need to know more. What are your fuel trims?

    • The problem is @ an idle and goes away above 1000 rpm. the spider injector had a poor spray pattern on the # 1 and 3. they had the injector replaced and the same problem. compression is good in all cylinders and is 125 to 130. used a scanner and tested the egr by increasing the %. used a vacuum gauge and the vacuum is bout 22. fuel flow is normal. the cap and rotor are new A/C delco. the wires are autolite 7mm. the distributor shaft might b grounding out @ idle.

  5. The problem is @ an idle and goes away above 1000 rpm. the spider injector had a poor spray pattern on the # 1 and 3. they had the injector replaced and the same problem. compression is good in all cylinders and is 125 to 130. used a scanner and tested the egr by increasing the %. used a vacuum gauge and the vacuum is bout 22. fuel flow is normal. the cap and rotor are new A/C delco. the wires are autolite 7mm. the distributor shaft might b grounding out @ idle.

  6. No scope. retired marine that helps people that cant afford real help. have had good classes and understand most. the compression test is good running. can the distributor be isolated to certain cylinders? I have the genisys scanner. will the crank sensor isolate only certain cylinders?

    • Travis Dewitz

      The only way to maybe see a distributor issue with just a scan tool would be to monitor the Cam Retard PID at 1000 RPM or higher. Should be steady.

  7. Mark Bryant

    I have 2000 Astro 4.3 with random misfire P0300 you only notice any issue when trying to maintain highway speed and then you feel the misfire let out of the fuel, add slight fuel, or pulling up a hill and it goes away. three shops have scoped it only consistent signs is random misfire on 6 of 5 cylinders. Occasionally it will throw a P0102 Mass or Volume Air Flow Circuit Low Input however it scopes out fine. The cam retard is @ -12 and only varies by 2. I have tried three used distributors from a friends garage and they showed the same. The misfire shows up worse on humid or rainy days. The distributor cap does collect green corrosion constantly. i have changed fuel pump, filter, cap and bug, wires, plugs, cat, cleaned the maf! Any idea?

    • Travis Dewitz

      A P0102 Mass or Volume Air Flow Circuit Low Input is most likely a bad MAF sensor. Other causes are wiring, TPS, or ECM. Usually when you have that code the MAF either works or doesn’t. When it is working it will test good. The misfire issue may or may not be related. The 4.3 distributors need the screens punched out since those are made for marine use and trap everything in the cap. You may have valve float issues or a number of other problems. More testing is needed.

  8. David M

    Hi, Travis I think I need a Crankshaft Sensor too I have the same symptoms with my 98 Astro 4.3 but my computer throws no codes. I have replaced the cap, wires, plugs, coil, ignition module, and fuel pump cause that had only 45 psi. It wants to start but won’t and you can hear the ark in the distributor cap.

    • Travis Dewitz

      Hear the ark? Not a valid test. You need to have a spark tester that can load the system, and start your test at the spark plug and work your way back. But if you do have spark, why would you need a crank sensor for a no start? Finding a shop that you can trust to do actual testing without just replacing parts would be worth its weight in gold in my book. Usually the good parts on your vehicle that have 100k on them are better then what you can buy new in the aftermarket which is why I use only a few trusted manufacturers. A lot of the time I see people almost fix their vehicles only to have defective new parts cause them to replace more. Testing correctly solves this issue.

  9. Heya, I just hopped over to your webpage thru StumbleUpon. Not somthing I would normally read, but I enjoyed your thoughts none the less. Thanks for creating some thing worth reading through.

  10. Joseph taldone

    This problem is pervasive on the 4.3 vortec. I have replaced everything listed here with no luck. The arcing sound from the distributor is under any load on my astro van. Frustrating part for me is that there are no codes. I have to replace the cap and rotor every 2 months. This problem started at 125000 miles and continues today at 200000.

  11. Dave M

    Joe,
    After working on these Astro’s for the past 10 years with all kinds of troubles from sway bars too spark plugs I found out that they didn’t build it very well, but it is still a very poplar vehicle.
    Keep in mind you have over 200k on this Astro so don’t put too much more into it, its tired…
    I also found that as they age weird problems arise.
    The passlock security will cause odd problems like no start conditions with out codes, when this happens people start throwing new parts at them. The coil wire at the coil will cause the coil to arc too ground in wet conditions. Vacuum problems causing lean conditions; at the intake or lines this also causes the timing to go wacky because the map sensor sends the load info to the computer and don’t get me started on the intake gaskets leaking antifreeze into the crank case…
    Good luck…

  12. Grayson

    I am currently working on a misfire on my Dad’s Safari, and I just wanted to say it has over 345,000 miles, all original powertrain. Only major component swapped was rear end about a year ago. These vans have a bad reputation, but I am thoroughly impressed with as long as his has held up.

  13. Dave M

    Grayson,
    Hope you worked out your misfire, coil wire, coil and cap is the first place I’d look; get it done because if its not fixed and the van is used with the misfire the catalytic converter will go $$$

    • Men, Ã¥terbetalningskyddet är ju ocksÃ¥ kopplat till möjligheten att gÃ¥ ta ut sin tjänstepension innan 65-Ã¥r Ã¥lder. GÃ¥r det i normalfallet att Ã¥terfÃ¥ sitt Ã¥terbetalningsskydd och sin rätt till pension innan 65-Ã¥r efter en hälsoprövning eller hur funkar det?Om du har koll pÃ¥ nÃ¥gon bra sammanställning av tidigaste pensionsÃ¥lder och pÃ¥verkan av Ã¥terbetalningskydd sÃ¥ är jag intresserad. Vad händer t.ex. med tidigaste pensionsÃ¥ldern för PPM som ju är 61-Ã¥r.

  14. Stan

    I chased a random misfire code for some time. Did the usual, cap rotor plugs wires etc… While at a U-Pick Junkyard I did some looking…I found that my timing gear at the bottom of the distributor shaft was worn where it contacts the cam gear. I swapped my worn one for a decent junkyard gear and it solved the problem! Also the assortment of vacuum lines that corrode and collapse over time. 200k plus on 1996 GMC Safari.

Leave a Reply

Your email address will not be published. Required fields are marked *

Get in touch with us!

Big or small, we’ve got a solution when you need it. Our advanced service and support tools provide step-by-stepinstructions without being put on hold or waiting in line.